5

I just a typed this piece of diaglogue in Scrivener 3.0.2 (1504)

“Certainly.”, she replied cheerfully and vanished.

Scrivener is auto-correcting/auto-captializing (not sure which) 'She' as shown below.

“Certainly.” She replied cheerfully and vanished.

I'm not sure if this is a bug or a option that I don't understand. Is there a way of fixing this issue relative to dialog that doesn't involved turning off auto-correct globally?

UPDATE: based on answers, if remove the erroneous comma, when I type:

“Certainly.” she replied cheerfully and vanished.

Scrivener still auto corrects to

“Certainly.” She replied cheerfully and vanished.

However, per the answer about using comma's within quotes, if I type:

“Certainly,” she replied cheerfully and vanished.

Scrivener doesn't correct anything. This seems to be inline with the American style of dialogue described below.

  • 1
    Just as a side note, I think a more common way of writing dialogue would be ""Certainly," she replied cheerfully and vanished." with the comma inside of the quotes. This could be what's throwing Scrivener off. – White Eagle May 17 '18 at 0:50
2

Stick with either the American or the British way for dealing with punctuation around quotations marks.

American style puts commas and periods within double quotations marks (style.mla.org; blog.apastyle.org):

“Certainly,” she replied cheerfully and vanished.

Using a period within the quotation marks would indicate an end of the sentence in American style. That's why Scrivener is auto-capitalizing.

British style puts commas and periods outside single quotation marks:

'Certainly', she replied cheerfully and vanished.

  • The British rule you describe is only partially correct. If the quotation itself contains punctuation, then it goes inside the quotation marks. Your example is correct, but so is: 'However,' she replied, 'I don't think this is wrong.' (Both the comma and period would exist in the quoted sentence.) This is detailed on page 16 of the University of Oxford Style Guide (ox.ac.uk/sites/files/oxford/media_wysiwyg/…). It took me a long time to figure this out. ;) – Jason Bassford Supports Monica May 17 '18 at 6:13
  • @jasonbassford is right, if you're referring to a novel with dialogue, your example is incorrect. We don't put punctuation outside the dialogue. We do use single quotation marks though. For a British submission, you would write: 'Certainly,' she replied. – GGx - Reinstate Monica Cellio May 17 '18 at 9:01
  • @GGx Actually, the example is correct. Per the University of Oxford: Bob likes cheese -> ‘Bob’, I said, ‘likes cheese.’ The original does not have any punctuation. Therefore, the comma goes outside the single quotation mark. Whether it goes inside or outside is based solely on what is being quoted, and how it would be punctuated if there were no quotation marks at all. In the example, it's a single word, so the comma goes outside. (The punctuation isn't related to the fact that it's dialogue, per se. Unless, of course, it's a different style guide being used . . .) – Jason Bassford Supports Monica May 17 '18 at 9:41
  • @JasonBassford ahh yes, absolutely, but as per my comment, I'm not talking about quoting what someone has said using the University of Oxford style guide. The OP is writing dialogue in Scrivener, I assume (and yes, I know the ass and u and me) for a novel. And if you submit a novel in the UK you wouldn't punctuate dialogue in that way, unless you want to look like you've never read a book and seen how dialogue should be formatted within one. We are talking at cross purposes over two completely different forms of writing. – GGx - Reinstate Monica Cellio May 17 '18 at 11:45
  • @GGx Quite so. Scrivener is likely not as discerning on those fine points. – Jason Bassford Supports Monica May 17 '18 at 14:17
3

Because “certainly.”, is incorrect. It’s either a period or a comma—not both.

0

I won't repeat what's already been said in terms of what you're typing being a mistake in punctuation.

But what you can do (although I would advise against it since it's helping to identify a problem) is to turn off Scrivener's Fix capitalization of sentences option, under the Corrections > Auto-Capitalization section. (On the Windows 3 beta anyway.)

That would stop the kind of correction you've identified from happening. However, it would also stop it from automatically capitalizing the first letter in any sentence that's typed in lowercase.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.