19

Why am I getting a strange double quote (“) in Open Office instead of the ordinary one (")?

Every time I type the double quote, I get the weird version instead of the ordinary one. How do I get the normal one instead when I type it? Is there a way to fix this unwanted behavior?

  • 12
    Technically, you're getting the (correct) double quote because Microsoft Word has always done that, and OpenOffice & LibreOffice try to be completely compatible. Personally, I'd be unimpressed if you sent me a document with straight quotes. – Auspex Jun 6 at 13:36
  • 1
    @Auspex - I think you're right about which quotes are technically the correct ones. But they aren't the correct ones “because Microsoft Word has always done that.” – J.R. Jun 7 at 21:08
  • Straight quotes exist because there's wasn't a pressing need to distinguish between left and right quotes in early character sets like ASCII, and available code points were limited. For actually producing documents, proper quotation marks should always be used. – chepner Jun 8 at 23:46
  • 1
    @J.R. No, they're not "correct English" because Microsoft has always used them. But they are the correct quotes for OpenOffice because Microsoft has always done that. "Technically", I said, not "grammatically". OpenOffice would have used Emoticons if that's what MS Office did! – Auspex Jun 11 at 13:04
43

I'd argue that quotation marks like “ ” are the ordinary ones, and quotation marks like " " are the strange ones. :) But if you prefer typewriter-style quotation marks, that's fine.

According to the OpenOffice wiki, you can change this behavior by opening the AutoCorrect options, clicking the “Localized Options” tab, and un-checking the “Replace” option in the “Double quotes” section.

For a screenshot, see: AOO AutoCorrect LocalizedOptions

  • 17
    I for one really appreciate it when writers use the correct quotation marks for their language. – Tomáš Zato - Reinstate Monica Jun 6 at 12:20
  • 6
    This feature sucks for technical documentation where most interfaces don't recognize the "ordinary" (<-- argh, straight quotes) ones. I hate copying a block of code and then getting numerous errors due to the quote type. – Hannover Fist Jun 6 at 21:38
  • 4
    @HannoverFist: Back when I used a classic Macintosh (1988 through 1996ish) I simply typed typographic quotes using, if memory serves, option-shift-leftbracket and option-shift-rightbracket. It annoys me that Windows has no keyboard options as nice as what Apple did do in the 30 years ago. – supercat Jun 6 at 22:48
  • 6
    @HannoverFist Unfortunately, this will always be a bit of a holy war between writers and programmers. I can't tell you the number of times an elusive bug has been traced to using the wrong kind of quotes in a data file (I've also seen people use two single quotes instead of one double, another source of frustration), that or em-dashes instead of hyphens, etc. – Darrel Hoffman Jun 7 at 15:44
  • 1
    @DarrelHoffman: The correct quote marks in my language „look like this“, so people occassionally use two commas as a substitute. Seeing ,,this'' in official, MS Word-written documents always makes me cringe. (They could have written "this" and it would have been autocorrected by Word, but no…) – grawity Jun 8 at 10:52
13

You need to go to Tools - Autocorrect - Autocorrect Options - Localised Options. There you can pick the kind of double quotes and single quotes you like. (Source. Note the source tries to do the exact opposite - get the curly quotation marks. Shouldn't make a difference though.)

12

In English, the “ordinary” quotes are the “upper 66” quotes for opening and the “upper 99” quotes for ending a quotation. In other languages, it's often “lower 66” for opening quotes, or «quotation marks» or »quotation marks« (French and German). The straight quotes are not correct in any language I know of; they have been invented for programmers. (They are called 66 and 99 quotes because that's what they look like really magnified).

PS. The question was: "Why am I getting a strange double quote". That is answered: You are getting what you believe are strange characters because they are the correct characters.

  • 6
    This looks more like a comment; it certainly isn't answering the question (how to change the editor's behaviour). – Toby Speight Jun 6 at 9:37
  • 13
    I think the straight quotes have their origin in typewriters actually: no two buttons for 66 and 99 quotes, no software to take care of the issue. – Galastel supports GoFundMonica Jun 6 at 9:40
  • 1
    This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – Galastel supports GoFundMonica Jun 6 at 10:56
  • 13
    I don't understand the "off-topic" comments. OP misunderstands which quotes are correct, this answer corrects them. That is a much better answer than "how to use Open Office", which really belongs on the Open Office help forums rather than here. – BlueRaja - Danny Pflughoeft Jun 6 at 14:07
  • 2
    In a way, this answer is a frame challenge (which is allowed) but it doesn't meet that threshold. In many places curly quotes are the norm and the OP is indeed wrong about that. But the question is how to toggle the type of quote from within a particular software program. Note my slight frame challenge there. "How to toggle" is neutral to which is the "right" form. It's possible to answer the question without sharing the OP's views on quote marks. – Cyn says make Monica whole Jun 6 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.