2

I did an install of Scrivener Version: 1.9.9.0 - 03 Oct 2018 on a Windows 10 computer.

In the paste, I know I used to be able to copy formatted text from any source and paste it as plain text into Scrivener using Ctrl+Shift+V.

That doesn't appear to work in this install.

Is this some new 'feature' for Scrivener?

If not, how could I fix this?

It's horrific having all those different styles at once.


BKlassen suggested "a simple trick to remove formatting from text is to paste it first into a simple notepad application and then copy again from there." This worked without fail.

weakdna said it "should be under Edit>Paste and Match style." This works occasionally for some reason.

  • 1
    Should be under Edit>Paste and Match style. – weakdna Jan 9 at 23:25
  • 3
    I don't think this is specific to technical writing, nor does expertise in technical writing necessarily help answer this question. It seems, rather, squarely a question about how to use Scrivener (which is on topic for us as being a specialized writing tool, see our subject scope). I removed the technical-writing tag. – a CVn Jan 10 at 10:05
  • 5
    a simple trick to remove formatting from text is to paste it first into a simple notepad application and then copy again from there – BKlassen Jan 10 at 16:32
1

I'm also using Scrivener 1.9.9.0 on Windows 10 as well. The Ctrl+Shift+V command still works for me. Your keyboard shortcuts settings may have gotten corrupted.

  • Go to Tools->Options (or press F12).
  • Select Keyboard and type 'Paste' into the filter box at the top.
  • Double-check the keyboard shortcut for 'Paste and Match Style'.
  • If it's not set or set to something else, you change it by selecting the action you want and assigning it where it says 'edit shortcut' at the bottom.

If it still doesn't work after setting up the shortcut again, there's a chance another program or utility on your computer may be intercepting the the command. Another possibility is if you have multiple languages or keyboard layouts installed like I do, the toggle command is Ctrl+Shift. If I screw up the timing on the keystrokes, I switch my keyboard layout and perform a different action than I intended.

0

In Scrivener (like many apps), you have two options. To Paste as is, or Paste and Match Style.

'Twas always thus, and always thus will be.'

Paste and Match Style treats the pasted text as if it were plain-text only in as in far as it removes inline formatting, hyperlinks, italics, etc. BUT it takes on all of the characteristics of the text surrounding the cursor position where it is pasted. That is, it matches the style of the working document.

This is so handy because you don't have to format text every time you paste.

So much so, that I have used the systems keyboard preferences to switch Paste and Paste and Match Style within the Scrivener app. So, my Paste command automatically matches the surrounding text with Ctrl-V (or cmd-V in my case) and I have to Ctrl-Shift-V to force it to retain the original style.

If you genuinely want plain text, i.e. neither the formatting of the original style, or the formatting of your working Scrivener document, you will have to follow the advice above and paste into a plain text editor, copy again, then paste in Scrivener without matching style.

HTH

  • I'd be content if the pasted text took on the formatting of my working Scrivener document when I use Paste and Match Style. But that's the problem; it's not. At least not consistently. Sometimes it works, sometimes it doesn't. – Innertube Jan 30 at 15:37
  • @Innertube When you select Paste and Match Style, does it keep the formatting of the original page you copied it from, or does it appear to take on a random style that doesn't match the surrounding text at all? – GGx Jan 30 at 15:47
  • It's pretty random. Mostly it'll come in at a larger font and I can't reduce it. But that can vary from section to section within a project. – Innertube Jan 31 at 22:46
  • @Innertube I can replicate your problem. But not if I use Styles on my entire document. Try this: Open a new document. Fill it with text. Then, Edit, Select All, and from the Styles drop down box, select the supplied style ‘Code Block’. This is font Menio, size 11. I suggest this style because it’s not easily confused with anything else. Then, go out to a web page, select a random piece of text that’s all coloured and formatted in unique ways and Paste and Match Style into the middle of your document. What happens? Does the text reformat to ‘Code Block’? – GGx Feb 1 at 12:39
  • I ask because, if you format blocks of text here and there as you go along, rather than selecting the entire document and giving the whole thing a style. You can leave blank lines here and there that have ‘No Style’, that is, the default style in your Scrivener preferences. At install, I think this is Palatino size 13. Which may explain why your pasted text is larger than the surrounding text. – GGx Feb 1 at 12:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.