2

I think I'm asking this correctly, but I'm trying to add a website to my research

https://en.wikipedia.org/wiki/K%C3%A1rm%C3%A1n_line (the ACTUAL website is https://en.wikipedia.org/wiki/Kármán_line , but ctr+c doesn't seem to like those fancy letters)

When I use that though and try to place it in research as a pdf (I tried both webkit and IE, both give the same errors) I get an error stating "The webpage could not be imported"

A few moments later another dialogue box pops up over that one if I don't hit ok stating

"Scrivener appears to be having trouble downloading the entire contents of this web page.

Do you wish to 'Import' the content downloaded this far or continue to 'Wait' and see if more data can be downloaded?"

Neither option does anything, and I believe that's just a pop up that occurs because it doesn't notice the initial error out.

I've asked this question on scrivener's official forum, but figured I'd widen my chances a bit as my google-fu did not seem to turn up any results this evening.

Appreciate the assistance!

  • So for the time I have found a work around. I opened the page in chrome and printed it to a pdf, I was then able to add it as a file to research and that seemed to work. If that's how I need to do it then that's fine...but I kind of would like to use the built in feature if I can. – Soully Oct 31 '18 at 10:48
2

I duplicated the problem and came up with a solution that (in the end) uses Scrivener's own feature.

  1. Use TinyURL to convert the website address into a shorter form. This converts https://en.wikipedia.org/wiki/K%C3%A1rm%C3%A1n_line into https://tinyurl.com/adv89oc.
  2. In Scrivener, use Research > Add > Web Page . . . and enter the converted URL.

Note that the problem continues to exist in the September beta of the new Scrivener 3.0 for Windows. So, raising the question with them to address the underlying issue is good.

  • I just attempted this, for clarity I'm on version 1.9.9.0, and it failed in the same fashion with both webkit and IE as it did last time. I don't think I was doing it incorrectly, but the tinyurl gave the same error as the actual page. – Soully Oct 31 '18 at 19:27
  • 1
    @Soully Ah. I see from the response that this will be fixed propely, and the workaround I gave only works in the current beta. – Jason Bassford Oct 31 '18 at 19:37
2

I just received a response from Scrivener's support forum, and it looks like I came across what is a known error and has been for some time (Odd that I couldn't find much about it in my googling, but that was probably more user error than anything). Here is a copy of the response:

You've encountered both one of the biggest shortcomings (the biggest, IMHO) in the current Windows version, and the most common solution to it. Importing Web pages has not worked properly for a couple of years. I think this is due to advances in Web page formatting that Scrivener's underlying program code could not address. The new version (which is currently in advanced beta testing, and will be version 3) should have this fixed. Until it's released (that date is not officially made known), the PDF method is about all there is.

So it looks like the work around I commented about on the question (using the browser to save the page as a pdf, then loading the file into Scrivener) is the only current work around.

That seems to be about all there is to it. The work around is a bit annoying but it isn't too far out of the way, but it does the job I'd want it too, onward to more writing and less procrastinating!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.