1

In Word it's quite easy to stop the CApitalization OF THe FIrst TWo LEtters, but I cannot figure out how to do it on Scrivener. How would I auto-correct this error?

  • This question may better belong in Scrivener's reddit or, better yet, its forums—not a site about writing generally. (Nevermind the forums, since it seems you dislike those. But not even reddit?) Also, @ZeissIkon, why so passive-aggressive? I think it's a valid feature to want. – verified_tinker Apr 27 '18 at 4:34
  • @DemetreSaghliani I commented, then realized I could edit the question to reduce the level of rant and disrespect. I'll delete my "passive aggressive" comment. – Zeiss Ikon Apr 27 '18 at 11:36
1

This is not a feature that you have to turn on in Scrivener - it's a general setting you have to use in Mac and apps like Scrivener would have to use this setting

From macworld.com: "How to fix typing two capitals in a row at a word’s start":

OS X does offer this setting system-wide as part of automatic spelling correction, and it works in all of Apple’s programs and is available in other apps that take advantage of it. This autocorrect will drop in what OS X thinks is the “correct” replacement as you type—it may sometimes be the wrong one if you’re using a specialized term or a special spelling. Generally, it’s the right choice.

Here is how it would work (emphasis mine):

This includes accidental miscapitalization. Type “OFfice” and the capital “O” is preserved, as autocorrect won’t set a capitalized word to lowercase; but the first “F” will transform to its downshifted equivalent after you press the spacebar. If you type any other punctuation after a the word, while the option will put a wavy red underline beneath the word, it won’t correct it—unless you wait for a brief moment for a pop-up to appear with the corrected word shown in blue. You can type any other character or click the blue word to accept the change, or click the X next to the word to reject it.

The setting can be found here:

In System Preferences, you can enable autocorrection in the Keyboard pane under Text. Check the Correct Spelling Automatically box. In individual apps, like TextEdit, Pages, or Mail, use the Edit > Spelling & Grammar sub-menu to make sure both Check Spelling While Typing and Correct Spelling Automatically have checkmarks.

Apparently many apps just take this setting and apply it - if Scrivener does this you should be good to go after turning this setting on the way the website describes it. If Scrivener does not use this setting you are in bad luck and have to simply take care of checking your writing.

There are no special features in this direction in Scrivener itself. That's also why you can't find a lot of discussion in the Scrivener forums about this.

| improve this answer | |
  • What about Windows users? – verified_tinker Apr 27 '18 at 11:40
  • @DemetreSaghliani There is no mention of such an option, so I'd say that there is no way to do this, but I can't verify this. – Secespitus Apr 27 '18 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.